DNS DoT Query Outage

Incident Report for FGD DNS DoT

Resolved

The incident has been resolved
Affected Component: US-West-2
End Time 2025-11-24 10:16:21 PST-0800
Posted Nov 24, 2025 - 10:17 PST

Investigating

We are currently investigating this issue
Affected Component: US-West-2
Start Time 2025-11-24 08:55:44 PST-0800
Posted Nov 24, 2025 - 08:58 PST
This incident affected: US West (US-West-2).